Search

Installing and Upgrading

Installation Requirements

To use MAMP PRO, your system must meet the following requirements

  • A working MAMP installation (MAMP can be downloaded directly from the MAMP PRO installation package).
  • Operating system: macOS Big Sur 11 or higher
  • A user account that belongs to the Admin group. Go to “System Preferences… > Users & Groups” to confirm.

Note: When upgrading from MAMP PRO 4 to MAMP PRO 5, 6 or 7, you will be prompted to upgrade your MySQL data to version 5.7. It is recommended that you upgrade your data. A copy of your old MySQL 5.6.x data will be kept in “/Library/Application Support/appsolute/MAMP PRO/db/mysql”.