FAQ > PHP

PHP 8 compatibility

If you select PHP version 8 in the settings of MAMP, you will receive a message that this PHP version may cause problems with the operation of your website.

These problems can occur because PHP 8 is a big step into the future of this programming language and old pigtails have now been cut off and a number of backward compatibilities have been removed. Also, at the current time (December 2020) not all common PHP extensions have been adapted to the new PHP version and also frequently used content management systems such as WordPress do not yet offer full support. But we would like to offer you PHP 8 so that you can adapt your PHP scripts and also your own themes or plugins for WordPress.

Additional Information