Troubleshooting > Remote

If your credentials fail, then first confirm your user name and password inputs are correct. If you have confirmed these are correct, then confirm the path provided is the remote document root for your public url domain.

The major PHP version on your remote server must be at least the same major version of your MAMP PRO host, e.g.: local host PHP version 7.0.27 will work with remote server PHP version 7.0.13 will have compatible version in order to start transferring.

Your remote web server type (Apache or Nginx) must be the same of your MAMP PRO host, e.g.: if your host web server is Apache, make sure you are uploading your files to an Apache remote web server.

You can check the possible errors below at Error code description if you receive an error when attempting to connect to your remote server.


Error codes

Below, you find all the possible error codes that you may receive when trying to upload or download your site to a remote server:

Error Code Meaning
-3001 Host with multiple databases mapped → Make sure that the selected host has one database mapped.
-3002 Missing remote server MySQL information → Enter all the fields on the remote tab.
-3003 Error while creating local temp folder. → Restart Mac.
-3004 Could not access the folder provided in the Path field → Make sure that remote document root folder exists on the remote server.
-3005,-3006 It was not possible to access the remote packages to execute the transfer → Contact developer
-3007 Error while adjusting local file → Restart Mac
-3008,-3009,-3022 MAMP PRO could not create remote folder → make sure that the ftp account has rights to read and write on remote server.
-3010 The provided Path (remote document root path) is wrong → Click on auto detect remote path.
-3011 The minimum requirements is not met with the remote server → Check the minimum requirements of MAMP PRO remote and contact your host provider.
-3012 The WordPress version locally is newer than the tested versions of WordPress in MAMP PRO.
-3013 The WordPress version locally is older than the tested versions of WordPress in MAMP PRO.
-3014 Could not verify the minimum requirements of the remote server → Check the minimum requirements of MAMP PRO remote and contact your host provider.
-3015 Could not start MySQL → Try again with the servers running.
-3016 Could not export MySQL Users → Contact support
-3017 Could not import local dump into remote MySQL server → Check minimum requirements, test again and contact support
-3018 Could not export MySQL Database → Contact support
-3019 Error while adjusting local database dump → Make sure your database is UTF8 and try again.
-3020 Error while adjusting local document root config file → Make sure your wp-config.php is UTF8 and try again.
-3021 Error while zipping document root → Restart your Mac
-3023 Error while unzipping remote document root → Check the minimum requirements and try again
-3024 Error while moving/activating remote document root → Check the minimum requirements and try again
-3101 Could not start MySQL → Try again with the servers running.
-3102, -3103, -3104 The host has no database mapped and it needs a new database → create a new database mapped to that host.
-3105 Missing remote server MySQL information → Enter all the fields on the remote tab
-3106 Error while creating local temp folder. → Restart Mac.
-3107 Could not access the folder provided in the Path field → Make sure that remote document root folder exists on the remote server.
-3108, -3109 It was not possible to access the remote packages to execute the transfer → Contact developer
-3110 Error while adjusting local file → Restart Mac.
-3111, -3112, -3118 MAMP PRO could not create remote folder → make sure that the ftp account has rights to read and write on remote server.
-3113 The provided Path (remote document root path) is wrong → Click on auto detect remote path.
-3114 Could not verify the minimum requirements of the remote server → Check the minimum requirements of MAMP PRO remote and contact your host provider.
-3115 The WordPress version locally is newer than the tested versions of WordPress in MAMP PRO.
-3116 The WordPress version locally is older than the tested versions of WordPress in MAMP PRO.
-3117 Could not verify the minimum requirements of the remote server → Check the minimum requirements of MAMP PRO remote and contact your host provider.
-3119 Error while exporting remote database → check minimum requirements, try again and contact developer.
-3120 Error while compressing remote document root → check minimum requirements and try again.
-3121 Error while unzipping local archive → restart your Mac and try again.
-3122 Error while adjusting remote database dump with local host information → contact developer.
-3123 Error while importing your remote database to your local database server → check requirements, try again and contact developer.
-3124 Error while adjusting wp-config.php file → Make sure the config file is UTF8, make sure it follows the standard WordPress wp-config.php file and try again.
-3125 Error while moving the new document root → restart your Mac and try again.